VMWare : erreur du module vmnet avec le Kernel 3.13

Ahahaha ! De jour en jour je découvre des trucs qui ne fonctionnent plus, depuis ma mise à jour vers Ubuntu 14.04 LTS. Après LibreOffice hier, aujourd'hui c'est au tour de VMware Workstation. Bon, avec vmware j'ai l'habitude. J'avais déjà eu un soucis avec Ubuntu 13.04 et son kernel 3.8...(ici). Cette fois, Workstation refusait de se lancer, et me renvoyait une erreur liée au module vmnet. J'ai d'abord tenté naïvement de relancer la config via la commande suivante, sans succès.

sudo vmware-modconfig --console --install-all

Du coup, me revoilà parti sur le net pour faire des recherches avec mon ami Google. 1er lien : un mec conseillait de repasser sur un kernel plus ancien en attendant un correctif de vmware... Ouais, ba non ! J'ai trouvé la solution, il convient de patcher le module vmnet pour le rendre compatible avec le kernel 3.13. Voici donc la manipulation.

 

Tout d'abord, il faut télécharger le patch. 

cd ~

wget https://www.justegeek.fr/dl/vmware-vmnet313.patch

Il faut ensuite patcher le module vmnet. Pour cela, il suffit de rentrer les commandes suivantes dans un terminal.

cd /usr/lib/vmware/modules/source

sudo tar -xvf vmnet.tar

sudo patch vmnet-only/filter.c < ~/vmware-vmnet313.patch

sudo tar -uvf vmnet.tar vmnet-only

sudo rm -r vmnet-only

 Voilà, il ne reste plus qu'à relancer la config vmware, et le module vmnet va se compiler.

sudo vmware-modconfig --console --install-all

 

 

 

Sandstorm

Sandstorm

Ingénieur Systèmes passionné d'informatique et de High-Tech, Sandstorm a créé JusteGeek.fr en 2013. Il aime les geekeries en tout genre. "Si un produit s'allume c'est un bon point. S'il est connecté, c'est encore mieux !"

Vous aimerez aussi...

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.